$re = '/^[0-9]{4}[A-Z]{4}$/m';
$str = '1234ABCD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);