package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bgo\b`)
var str = `"go,godown,goup,go,ago,agon,aerugos,gone,going,good,goof,goaway,nogo,go"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}