$re = '/\bgo\b/';
$str = '"go,godown,goup,go,ago,agon,aerugos,gone,going,good,goof,goaway,nogo,go"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);