#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\\)(%.*?(?<!\\)%)"
Local $sString = "%Aliquam hendrerit mollis pretium! Praesent id%" & @CRLF & _
"%molestie \*libero vel\%\% pulvinar? Sed%" & @CRLF & _
"\%% urna. \% Fusce% in *sapien %mau\*ris.%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")