$re = '/(?<!\\\\)(%.*?(?<!\\\\)%)/';
$str = '%Aliquam hendrerit mollis pretium! Praesent id%
%molestie \\*libero vel\\%\\% pulvinar? Sed%
\\%% urna. \\% Fusce% in *sapien %mau\\*ris.%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);