# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[cC][hH]|[lL][lL]|[rR][rR]|[qQ][uU]|[mnñvzsyjhxwMNÑVZSYJHXW]|[fpbtdkgcFPBTDKGC][lrLR]?|[lrLR])?(?:[iuüIUÜ][eaoéáóEAOÉÁÓ][iyuIYU]|[aáAÁ][hH]?[uúUÚ][aáAÁ]|[iuüIUÜ][hH]?[eaoéáóEAOÉÁÓ]|[eaoéáóEAOÉÁÓ][hH]?[iyuIYU]|[iíIÍ][hH]?[uúUÚ]|[uúüUÚÜ][hH]?[iíyIÍY]|[ieaouíéáóúüIEAOUÍÉÁÓÚÜ])(?:(?:(?:(?:[nmNM]|[rR](?![rR]))s?(?![ieaouíéáóúüIEAOUÍÉÁÓÚÜ]))|(?:(?:[mnñvzsyjhxwMNÑVZSYJHXW]|[lL](?![lL]))(?![ieaouíéáóúüIEAOUÍÉÁÓÚÜ]))|(?:(?:[fpbtdkgFPBTDKG]|[cC](?![hH]))(?![lrLR]?[ieaouíéáóúüIEAOUÍÉÁÓÚÜ])))(?!\s|$))?(?:[ndrlsxNDRLSX](?=\s|$))?"
test_str = ("SÍLABA CV\n"
" casado\n"
" caro\n\n"
"NÚCLEOS VOCÁLICOS\n"
" DIPTONGOS\n"
" ai, au, ei, eu, oi, ou, ui, iu, ia, ua, ie, ue, io, uo\n"
" varió comió diario miel\n\n"
" CON DOS CERRADAS\n"
" distribuido atribuir atribuí\n"
" muy fui rey\n"
" pausa tierra\n"
" ciudad buitre \n\n"
" CON H INTERCALADA\n"
" desahuciar, ahijado\n\n"
" TRIPTONGOS\n"
" santigüeis\n"
" guay guau rey\n"
" haliéutica hioides huaico\n\n"
" AUA\n"
" palauano\n"
" nahuatl cacahuatal\n\n"
" HIATOS NORMATIVOS (DOS CONSONANTES ABIERTAS)\n"
" aorta\n"
" héroe\n"
" almohada\n"
" línea\n\n"
" HIATOS\n"
" tú sabrías, sabías, vosotros sabíais\n"
" raúl oído búho\n"
" tío púa \n\n"
"ATAQUE C+LÍQUIDA\n"
" cromo\n"
" claro\n"
" cabra\n"
" triple\n"
" dígrafos \n\n\n"
"CODAS\n"
" silbo\n"
" cansado\n"
" tacto\n"
" texto\n"
" anticiparse\n"
" álbumes\n"
" asfixia\n"
" enloquecer\n\n"
" SUCESIÓN NS MS RS\n"
" transportar\n"
" transacción\n"
" torso\n"
" perspectivas\n"
" samsara \n\n"
" CODAS A FINAL DE PALABRA\n"
" hablan hablar hablad\n"
" riel rieles\n"
" sílex\n"
" recto\n\n"
"DÍGRAFOS\n"
" chica\n"
" coche\n"
" llave\n"
" calle\n"
" carro\n\n"
"EXTRANJERISMOS\n"
" pícnic\n"
" hámster\n"
" mozzarella\n"
" marketing\n"
" búnker\n"
" sándwich\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.