import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[[^][]*]|\\([^()]*\\)|\\{[^\\{\\}]*\\})(*SKIP)(*F)|[^][()\\{\\}]+";
final String string = "Hello [123] {45} world (67)\n"
+ "Hello There (8) [9] {0}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}