re = /(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|[^][(){}]+/m
str = 'Hello [123] {45} world (67)
Hello There (8) [9] {0}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result