package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\x{0400}-\x{0450}]+`)
var str = `возбраняется`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}