$re = '/[\x{0400}-\x{0450}]+/';
$str = 'возбраняется';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);