$re = '#^(?:.*?;){2}\K.*?(?=;)#mi';
$str = 'жаба;корова;собака и кошка; конь; человек';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);