re = /^(?:.*?;){2}\K.*?(?=;)/mi
str = 'жаба;корова;собака и кошка; конь; человек'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end