package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/Date\((\d+)([-+])(\d+)\)\/`)
var str = `/Date(1496351871147-0500)/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}