$re = '/\/Date\((\d+)([-+])(\d+)\)\//';
$str = '/Date(1496351871147-0500)/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);