using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://www\.104\.com\.tw/company/.+";
string input = @"https://www.104.com.tw/company/aw5oe14?jobsource=checkc
https://www.104.com.tw/company/18sepdbk?jobsource=check";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}