package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://www\.104\.com\.tw/company/.+`)
var str = `https://www.104.com.tw/company/aw5oe14?jobsource=checkc
https://www.104.com.tw/company/18sepdbk?jobsource=check`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}