package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.heart::after\s*{\s*([\w\-]+\s*:\s*[\w]+\s*;\s*)*background-color\s*:\s*pink\s*(\}|;)`)
var str = `// Solution
<style>
.heart {
position: absolute;
margin: auto;
top: 0;
right: 0;
bottom: 0;
left: 0;
background-color: pink;
height: 50px;
width: 50px;
transform: rotate(-45deg);
}
.heart::after {
background-color: pink;
content: "";
border-radius: 50%;
position: absolute;
width: 50px;
height: 50px;
top: 0px;
left: 25px;
}
.heart::before {
content: "";
background-color: pink;
border-radius: 50%;
position: absolute;
width: 50px;
height: 50px;
top: -25px;
left: 0px;
}
</style>
<div class="heart"></div>
// Correct Syntax + valid
.heart::after{
width: 100px;
color: red;
background-color: pink;
}
{}
// one liner
.heart::after{width: 100px;color:red;background-color: pink}
// Invalid Syntax - Not matching
.heart::after{
width: 1em
color: red;
background-color: pink;
height: 4;
}
.heart::after{background-color:pink;color:red;}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}