const regex = /\.heart::after\s*{\s*([\w\-]+\s*:\s*[\w]+\s*;\s*)*background-color\s*:\s*pink\s*(\}|;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.heart::after\\s*{\\s*([\\w\\-]+\\s*:\\s*[\\w]+\\s*;\\s*)*background-color\\s*:\\s*pink\\s*(\\}|;)', 'gm')
const str = `// Solution
<style>
.heart {
position: absolute;
margin: auto;
top: 0;
right: 0;
bottom: 0;
left: 0;
background-color: pink;
height: 50px;
width: 50px;
transform: rotate(-45deg);
}
.heart::after {
background-color: pink;
content: "";
border-radius: 50%;
position: absolute;
width: 50px;
height: 50px;
top: 0px;
left: 25px;
}
.heart::before {
content: "";
background-color: pink;
border-radius: 50%;
position: absolute;
width: 50px;
height: 50px;
top: -25px;
left: 0px;
}
</style>
<div class="heart"></div>
// Correct Syntax + valid
.heart::after{
width: 100px;
color: red;
background-color: pink;
}
{}
// one liner
.heart::after{width: 100px;color:red;background-color: pink}
// Invalid Syntax - Not matching
.heart::after{
width: 1em
color: red;
background-color: pink;
height: 4;
}
.heart::after{background-color:pink;color:red;}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}