import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{3}(?!.*\\d{3}.*string)(?=.*string)";
final String string = "000 111 222 333 string 444 555 666\n"
+ "000 111 222 333 sdfasdjf;sdfjn 999 skljdfn\\;sdlfn\\sd string 444 555 666";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}