$re = '/\d{3}(?!.*\d{3}.*string)(?=.*string)/m';
$str = '000 111 222 333 string 444 555 666
000 111 222 333 sdfasdjf;sdfjn 999 skljdfn\\;sdlfn\\sd string 444 555 666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);