package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?\d+\.?(\d+)?|\w+`)
var str = `7.23 SSWAB 38 15 - 57 -2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}