$re = '/-?\d+\.?(\d+)?|\w+/m';
$str = '7.23 SSWAB 38 15 - 57 -2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);