const regex = /[A-Z].*\s[0-9,].+\|$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z].*\\s[0-9,].+\\|$', '')
const str = `Peter 50|alex|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}