$re = '/[A-Z].*\s[0-9,].+\|$/';
$str = 'Peter 50|alex|';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);