import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{6}(?:\\d{3})?\\b";
final String string = "ID 123 - it should not meet the regext as it is 3 digits\n"
+ "ID 1234 - it should not meet the regext as it is 4 digits\n"
+ "ID 12345 - it should not meet the regext as it is 5 digits\n"
+ "ID 123456 - it should meet the regex it is 6 digits <==========\n"
+ "ID 1234567 - it should not meet the regext as it is 7 digits\n"
+ "ID 12345678 - it should not meet the regext as it is 8 digits\n"
+ "ID 123456789 - it should meet the regext as it is 9 digits <==========\n"
+ "ID 1234567890 - it should not meet the regext as it is 10 digits\n"
+ "ID 12345678901 - it should not meet the regext as it is 11 digits";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}