re = /^(?=.*\/\*).+$/m
str = 'Hello NO MATCH
123 NO MATCH
/* HELLo MATCH
/*4534534 MATCH
fsdggg(((*/*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end