#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(\w+)":\s"?([^",{}]+)"?"
Local $sString = "{" & @CRLF & _
" "response": {" & @CRLF & _
" "first_name": "Степан"," & @CRLF & _
" "last_name": "Воробьёв"," & @CRLF & _
" "screen_name": "sparrowwwwww"," & @CRLF & _
" "sex": 2," & @CRLF & _
" "relation": 7," & @CRLF & _
" "bdate": "14.2.1995"," & @CRLF & _
" "bdate_visibility": 2," & @CRLF & _
" "home_town": "Санкт-Петербург"," & @CRLF & _
" "country": {" & @CRLF & _
" "id": 1," & @CRLF & _
" "title": "Россия"" & @CRLF & _
" }," & @CRLF & _
" "city": {" & @CRLF & _
" "id": 2," & @CRLF & _
" "title": "Санкт-Петербург"" & @CRLF & _
" }," & @CRLF & _
" "status": ""," & @CRLF & _
" "phone": "+7 7** *** ** 92"" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")