using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(\w+)"":\s""?([^"",{}]+)""?";
string input = @"{
""response"": {
""first_name"": ""Степан"",
""last_name"": ""Воробьёв"",
""screen_name"": ""sparrowwwwww"",
""sex"": 2,
""relation"": 7,
""bdate"": ""14.2.1995"",
""bdate_visibility"": 2,
""home_town"": ""Санкт-Петербург"",
""country"": {
""id"": 1,
""title"": ""Россия""
},
""city"": {
""id"": 2,
""title"": ""Санкт-Петербург""
},
""status"": "",
""phone"": ""+7 7** *** ** 92""
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}