package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d(?:\.\d{2})?$`)
var str = `6
6.21
6.2
6.
43`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}