$re = '/^\d(?:\.\d{2})?$/m';
$str = '6
6.21
6.2
6.
43';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);