using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<b>(?=[A-Z\s]*[a-z])(?=[a-z\s]*[A-Z])[\sA-Za-z]*(?:\(ecg\))?<\/b>";
string input = @"<b>TEST (ecg)</b>
<b>JAMES SMITH (ecg)</b>
<b>TeST (ecg)</b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}