$re = '/<b>(?=[A-Z\s]*[a-z])(?=[a-z\s]*[A-Z])[\sA-Za-z]*(?:\(ecg\))?<\/b>/m';
$str = '<b>TEST (ecg)</b>
<b>JAMES SMITH (ecg)</b>
<b>TeST (ecg)</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);