#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!bar)foo(?!bar)"
Local $sString = "foo" & @CRLF & _
"foo bar" & @CRLF & _
"bar foo" & @CRLF & _
"string foo" & @CRLF & _
"stringfoo" & @CRLF & _
"foo. string" & @CRLF & _
"barfoo" & @CRLF & _
"foobar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")