$re = '/(?<!bar)foo(?!bar)/m';
$str = 'foo
foo bar
bar foo
string foo
stringfoo
foo. string
barfoo
foobar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);