#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|//.*"
Local $sString = "import android.content.res.Resources;" & @CRLF & _
" import android.os.Handler;" & @CRLF & _
" import android.preference.PreferenceFragment;" & @CRLF & _
" import android.view.ViewGroup;" & @CRLF & _
" * Provides the regex to identify domain HTTP(S) protocol and/or 'www' sub-domain." & @CRLF & _
" *" & @CRLF & _
" * Used to format user-facing {@link String}'s in certain preferences." & @CRLF & _
" */" & @CRLF & _
" public static final String ADDRESS_FORMAT_REGEX = "^(https?://(w{3})?|www\\.)";" & @CRLF & _
"" & @CRLF & _
" /**" & @CRLF & _
" // Used to ensure that settings are only fetched once throughout the lifecycle of the fragment" & @CRLF & _
" private boolean mShouldFetch;" & @CRLF & _
"" & @CRLF & _
" public View onCreateView(@NonNull LayoutInflater inflater," & @CRLF & _
" ViewGroup container," & @CRLF & _
" Bundle savedInstanceState) {" & @CRLF & _
" // use a wrapper to apply the Calypso theme" & @CRLF & _
" Context themer = new ContextThemeWrapper(getActivity(), R.style.Calypso_SiteSettingsTheme);" & @CRLF & _
" LayoutInflater localInflater = inflater.cloneInContext(themer);" & @CRLF & _
" View view = super.onCreateView(localInflater, container, savedInstanceState);" & @CRLF & _
"" & @CRLF & _
" if (view != null) {" & @CRLF & _
" setupPreferenceList((ListView) view.findViewById(android.R.id.list), getResources());" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" return view;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Override" & @CRLF & _
" public void onChildViewAdded(View parent, View child) {" & @CRLF & _
" if (child.getId() == android.R.id.title && child instanceof TextView) {" & @CRLF & _
" // style preference category title views" & @CRLF & _
" TextView title = (TextView) child;" & @CRLF & _
" WPPrefUtils.layoutAsBody2(title);" & @CRLF & _
" } else {" & @CRLF & _
" // style preference title views" & @CRLF & _
" TextView title = (TextView) child.findViewById(android.R.id.title);" & @CRLF & _
" if (title != null) WPPrefUtils.layoutAsSubhead(title);" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Override" & @CRLF & _
" public void onChildViewRemoved(View parent, View child) {" & @CRLF & _
" // NOP" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @Override"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")