# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|//.*"
test_str = ("import android.content.res.Resources;\n"
" import android.os.Handler;\n"
" import android.preference.PreferenceFragment;\n"
" import android.view.ViewGroup;\n"
" * Provides the regex to identify domain HTTP(S) protocol and/or 'www' sub-domain.\n"
" *\n"
" * Used to format user-facing {@link String}'s in certain preferences.\n"
" */\n"
" public static final String ADDRESS_FORMAT_REGEX = \"^(https?://(w{3})?|www\\\\.)\";\n\n"
" /**\n"
" // Used to ensure that settings are only fetched once throughout the lifecycle of the fragment\n"
" private boolean mShouldFetch;\n\n"
" public View onCreateView(@NonNull LayoutInflater inflater,\n"
" ViewGroup container,\n"
" Bundle savedInstanceState) {\n"
" // use a wrapper to apply the Calypso theme\n"
" Context themer = new ContextThemeWrapper(getActivity(), R.style.Calypso_SiteSettingsTheme);\n"
" LayoutInflater localInflater = inflater.cloneInContext(themer);\n"
" View view = super.onCreateView(localInflater, container, savedInstanceState);\n\n"
" if (view != null) {\n"
" setupPreferenceList((ListView) view.findViewById(android.R.id.list), getResources());\n"
" }\n\n"
" return view;\n"
" }\n\n"
" @Override\n"
" public void onChildViewAdded(View parent, View child) {\n"
" if (child.getId() == android.R.id.title && child instanceof TextView) {\n"
" // style preference category title views\n"
" TextView title = (TextView) child;\n"
" WPPrefUtils.layoutAsBody2(title);\n"
" } else {\n"
" // style preference title views\n"
" TextView title = (TextView) child.findViewById(android.R.id.title);\n"
" if (title != null) WPPrefUtils.layoutAsSubhead(title);\n"
" }\n"
" }\n\n"
" @Override\n"
" public void onChildViewRemoved(View parent, View child) {\n"
" // NOP\n"
" }\n\n"
" @Override")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.