const regex = /(?<=<!--([A-Z]\d)-->)[\s\S]*?(?=<!--\1END-->)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<!--([A-Z]\\d)-->)[\\s\\S]*?(?=<!--\\1END-->)', 'gs')
const str = `<!--Q1-->
\\nフレンチブルドックと遊んでるとき\\n
<!--Q1END-->\\n
<!--Q2-->
\\n表参道、新宿、銀座\\n
<!--Q2END-->\\n
<!--Q3-->
\\nヒューマンドラマ全般が好きです。<BR>\\n<BR>\\n好きなアーティスト サザンオールスターズ\\n
<!--Q3END-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}