$re = '/(?<=<!--([A-Z]\d)-->)[\s\S]*?(?=<!--\1END-->)/s';
$str = '<!--Q1-->
\\nフレンチブルドックと遊んでるとき\\n
<!--Q1END-->\\n
<!--Q2-->
\\n表参道、新宿、銀座\\n
<!--Q2END-->\\n
<!--Q3-->
\\nヒューマンドラマ全般が好きです。<BR>\\n<BR>\\n好きなアーティスト サザンオールスターズ\\n
<!--Q3END-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);