package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\.(\d+)\.(\d)+(?:-(\d+))?`)
var str = `2.18.0-10597
2.18.20
10.23.1-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}