$re = '/^(\d+)\.(\d+)\.(\d)+(?:-(\d+))?/m';
$str = '2.18.0-10597
2.18.20
10.23.1-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);