import re
regex = re.compile(r"^([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]) (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$", flags=re.MULTILINE)
test_str = ("2000-10-22 23:59:59\n"
"2000-10-22 23.59.59\n"
"2000-10-22 24:59:59\n"
"2000-10-22 22:99:59\n"
"2000-10-22 01:01:01\n"
"2000-10-22 2:59:59\n\n"
"// You can show origina post on albertcolom.com/blog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")