re = /^([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]) (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$/m
str = '2000-10-22 23:59:59
2000-10-22 23.59.59
2000-10-22 24:59:59
2000-10-22 22:99:59
2000-10-22 01:01:01
2000-10-22 2:59:59
// You can show origina post on albertcolom.com/blog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end