$re = '/Client[\n]{2}.*\s{5}(.*)/m';
$str = 'Furnizor Client
CATE-N LUNA SI-N STELE SRL Distribution Services Management
CIF: RO39679960 SRL
Reg. com.: J35/2590/2018 CIF: RO38144062
Furnizor Client
CATE-N LUNA SI-N STELE SRL Distribution Services Management
CIF: RO39679960 SRL
Reg. com.: J35/2590/2018 CIF: RO38144062';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);