import Foundation
let pattern = #"Client[\n]{2}.*\s{5}(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Furnizor Client
CATE-N LUNA SI-N STELE SRL Distribution Services Management
CIF: RO39679960 SRL
Reg. com.: J35/2590/2018 CIF: RO38144062
Furnizor Client
CATE-N LUNA SI-N STELE SRL Distribution Services Management
CIF: RO39679960 SRL
Reg. com.: J35/2590/2018 CIF: RO38144062
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)