$re = '/([Aa][AB]|[AB](?=([aA])))/m';
$str = 'AbAAaA
# exactly 3 red touching pyramid
# Trova 2 match e non 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);