re = /([Aa][AB]|[AB](?=([aA])))/m
str = 'AbAAaA
# exactly 3 red touching pyramid
# Trova 2 match e non 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end