const regex = /Android 4.[0-3].[0-9]*;.*Safari/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Android 4.[0-3].[0-9]*;.*Safari', 'gm')
const str = `Mozilla/5.0 (Linux; U; Android 4.1.1; ru-ru; GU110A Build/JRO03H) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}