re = /Android 4.[0-3].[0-9]*;.*Safari/m
str = 'Mozilla/5.0 (Linux; U; Android 4.1.1; ru-ru; GU110A Build/JRO03H) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end