package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)first_.*_motor_speed`)
var str = `first_01_motor_speed
first_01_line_speed
first_b_motor_speed
first_c_motor_speed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}