// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)first_.*_motor_speed").unwrap();
let string = "first_01_motor_speed
first_01_line_speed
first_b_motor_speed
first_c_motor_speed";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}